Sniper & Sharpshooter Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hi all,my B E 3 been working fine for the last couple of months on my 308,then the range finder wont read distance.After I press the go button twice,the four horizontal lines show up on the top line instead of distance numbers.lThe retical dots show down the custom ballistic plex post.
Battary good,everything else works.I tried to get a reading of clay banks,my truck,few buildings,have scope on 12x and 16 x.plex set at 200yds for ranging around the 200yd to 300yd.Scope been very accurate out to 600yds,zero on a 100yds.Shot a few bunnies out to 500yds,easy as.No trouble shooting 1/4 moa at 400yds and 600yds.
Any advice gratefully received.
 

·
Registered
Joined
·
2,949 Posts
Try replacing the battery. If that doesn't do anything then contact Burris (not Bushnell :cool:)
 

·
Registered
Joined
·
750 Posts
I had a minor problem with mine after it had sat for a while. I basically removed the battery and then spun it in it's holder. I'm guessing it was a poor connection. Also the other morning it wouldn't range because of heavy fog(?).

Hope you get yours figured out.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Hi Guys,Iv done the battery thing,all electrics work well,except range finder.Has clean glass and had about 60rds fired under it.Been working fine till 2 weeks ago.Guess il have to take it back (dam)Scope hasnt been on a day hunt yet,And its yearling time in NZ now.Il let you know the problem.Cheers Mozzy 308.
 

·
Registered
Joined
·
1 Posts
Hi all,my B E 3 been working fine for the last couple of months on my 308,then the range finder wont read distance.After I press the go button twice,the four horizontal lines show up on the top line instead of distance numbers.lThe retical dots show down the custom ballistic plex post.
Battary good,everything else works.I tried to get a reading of clay banks,my truck,few buildings,have scope on 12x and 16 x.plex set at 200yds for ranging around the 200yd to 300yd.Scope been very accurate out to 600yds,zero on a 100yds.Shot a few bunnies out to 500yds,easy as.No trouble shooting 1/4 moa at 400yds and 600yds.
Any advice gratefully received.
I’m having the same problem. Exact same problem. I meticulously maintain my stuff too. Sat in the safe for a year since last hunting season and now I get it out and it doesn’t work. Replaced the battery - still get four lines. What was your solution? Sent it back to Burris?


Sent from my iPhone using Tapatalk Pro
 

·
Banned
Joined
·
19 Posts
Battary good,everything else works.I tried to get a reading of clay banks,my truck,few buildings,have scope on 12x and 16 x.plex set at 200yds for ranging around the 200yd to 300yd.Scope been very accurate out to 600yds,zero on a 100yds.Shot a few bunnies out to 500yds,easy as.No trouble shooting 1/4 moa at 400yds and 600yds. Lucky Patcher Kodi nox
 

·
Registered
Joined
·
1 Posts
Hi all,my B E 3 been working fine for the last couple of months on my 308,then the range finder wont read distance.After I press the go button twice,the four horizontal lines show up on the top line instead of distance numbers.lThe retical dots show down the custom ballistic plex post.
Battary good,everything else works.I tried to get a reading of clay banks,my truck,few buildings,have scope on 12x and 16 x.plex set at 200yds for ranging around the 200yd to 300yd.Scope been very accurate out to 600yds,zero on a 100yds.Shot a few bunnies out to 500yds,easy as.No trouble shooting 1/4 moa at 400yds and 600yds.
Any advice gratefully received.
Hi have you managed to solve your Burris '4 horisontal lines' issue? I went hunting last week and in the field experienced the same. Cant range anything since
 
1 - 9 of 9 Posts
Top